Problem with 'Forgot your password' function

Hello everyone

During the past week we’ve been receiving quite a number of emails and notifications from members who have tried to renew their passwords but found that the ‘Forgot your password’ function is not working on the sign in screen.

We’re really sorry about this and will manually create new passwords for members as soon as we can (hopefully within the next couple of days)

If you’ve been affected by this technical issue, thank you for your patience while we resolve it.

With good wishes


Hi, I need help with a problem that happened recently

I logged out of an account and once I tried to log in again the password didn’t work. I assumed that I typed it in the wrong when I was making the account so I tried to click the forgot password option. I entered the correct stuff and when it said an email was sent, no email came. I tried the forgot username and it worked, so I’m using the correct email address. but the forgot password option doesn’t work. I sent an email to Carersuk contact but they haven’t responded yet so I am trying to see if anyone here can help me as well.

Hi Ravi

A few people have been having problems with this, as Michael has reported. It looks like it’s a problem at the technical end, so he’s probably the best person to contact!